Commit 7f7ab6ed authored by Michał Kaliński's avatar Michał Kaliński

Made compatible with Ubuntu 16.

parent 1e9e6539
......@@ -42,6 +42,11 @@ target_link_libraries(corpus2_mwereader ${LIBS})
set_target_properties(corpus2_mwereader PROPERTIES
VERSION "${libmwereader_major}.${libmwereader_minor}"
SOVERSION ${libmwereader_major})
# Newer LibXML++ requires c++11
if(NOT ${LibXML++_PKGCONF_VERSION} VERSION_LESS 2.40)
set_target_properties(corpus2_mwereader PROPERTIES
CXX_STANDARD 11)
endif()
install(TARGETS corpus2_mwereader
......
......@@ -11,3 +11,8 @@ add_executable( mwtests
)
target_link_libraries(mwtests corpus2_mwereader ${LIBS} antlr)
add_custom_target(mwtest mwtests --log_level=message)
# Newer LibXML++ requires c++11
if(NOT ${LibXML++_PKGCONF_VERSION} VERSION_LESS 2.40)
set_target_properties(mwtests PROPERTIES
CXX_STANDARD 11)
endif(NOT ${LibXML++_PKGCONF_VERSION} VERSION_LESS 2.40)
......@@ -27,7 +27,7 @@ link_directories(${Libwccl_BINARY_DIR})
FIND_PACKAGE(SWIG REQUIRED)
INCLUDE(${SWIG_USE_FILE})
find_package(PythonLibs)
find_package(PythonLibs 2)
find_package(PythonInterp)
# idea taken from pyplot build system
execute_process(
......
......@@ -49,6 +49,11 @@ add_executable(tests
)
target_link_libraries ( tests wccl ${LIBS} )
# Newer LibXML++ requires c++11
if(NOT ${LibXML++_PKGCONF_VERSION} VERSION_LESS 2.40)
set_target_properties(tests PROPERTIES
CXX_STANDARD 11)
endif(NOT ${LibXML++_PKGCONF_VERSION} VERSION_LESS 2.40)
include_directories(${Boost_INCLUDE_DIR})
link_directories(${Boost_LIBRARY_DIRS})
......@@ -56,4 +61,3 @@ link_directories(${Boost_LIBRARY_DIRS})
add_custom_target(test tests)
add_dependencies(test mwtest)
add_custom_target(test-verbose test --log_level=message)
......@@ -30,6 +30,17 @@ add_executable(wccl-rules wccl-rules.cpp)
target_link_libraries (wccl-rules wccl ${Boost_LIBRARIES} antlr ${LIBS})
add_executable(wccl-parser wccl-parser.cpp)
target_link_libraries (wccl-parser wccl ${Boost_LIBRARIES} antlr ${LIBS})
# Newer LibXML++ requires c++11
if(NOT ${LibXML++_PKGCONF_VERSION} VERSION_LESS 2.40)
set_target_properties(wccl-features PROPERTIES
CXX_STANDARD 11)
set_target_properties(wccl-run PROPERTIES
CXX_STANDARD 11)
set_target_properties(wccl-rules PROPERTIES
CXX_STANDARD 11)
set_target_properties(wccl-parser PROPERTIES
CXX_STANDARD 11)
endif(NOT ${LibXML++_PKGCONF_VERSION} VERSION_LESS 2.40)
install(TARGETS wccl-features wccl-run wccl-rules wccl-parser
RUNTIME DESTINATION bin
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment